Invalid Procedure Call or Argument

Få hjælp til oprettelse af hjemmesider, det kan være fra Legacy eller fra andre meget anvendte programmer til dette.

Redaktører: Testere, Oversættergruppe

Airtime
Indlæg: 73
Tilmeldt: man 23-02-2009 14:50
Geografisk sted: Gistrup
Kontakt:

Invalid Procedure Call or Argument

Indlægaf Airtime » lør 02-12-2023 12:56

Jeg forsøger at oprette en Hjemmesidefil (Anetavle).
Efter nogle sekunder kommer denne meddelelse "Invalid Procedure Call or Argument".
Trykker jeg på "Ok" i meddelelsen kommer meddelelsen igen efter få sekunder.
Når jeg har gjort det nogle gange, laver Legacy en hjemmefil for et x antal personer, hvorefter meddelelsen igen kommer.
Trykker jeg igen "Ok" sker det samme igen og igen og antal personer stiger hver gang med nogle få hundrede.

Hvad kan der være galt?
Med venlig hilsen
Erik Brindt
Legacy Deluxe 9.0.0.449 + Windows 10

Brugeravatar
Anne Marie H
Teamleder
Indlæg: 5119
Tilmeldt: søn 22-05-2005 22:17
Geografisk sted: Greve
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Anne Marie H » lør 02-12-2023 23:32

Venlig hilsen
Anne Marie Holck (Legacy Deluxe 9.0.0.456 + Windows 11)

Airtime
Indlæg: 73
Tilmeldt: man 23-02-2009 14:50
Geografisk sted: Gistrup
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Airtime » søn 03-12-2023 20:57

Jeg har, efter vejledningen i dit link, prøvet følgende uden held:
A. Filvedligeholdelse.
B. Reinstallation af Legacy efterfulgt af filvedligeholdelse.
C. Slettet antivirusprogrammer efterfulgt af filvedligeholdelse.

Vejledningens punkt 3 og 4 overstiger nok mine evner, så nedennævnte er ikke forsøgt.
3. Reset Legacy’s temporary folder by clicking on Options > Customize > Locations. Next, click the Reset button for the Location of Temporary File.
4. If the above steps fails to fix the problem, export your records into a new Legacy family file:
[o.s.v.]

Den sidste mulighed:
"Try Legacy again. It should run without error 5. If it still gives error 5 try the repair steps for crashing and freezing at http://legacyfamilytree.host4kb.com/article/AA-00865.
er et link uden indhold.

Jeg undrer mig over, at hvis jeg laver en Hjemmesidefil med alle personer der er mrk. "1", kører det fint. :?:

Kan jeg være sikker på, at det ikke er en fejl i ver. 9.0.0.449 :?: Jeg har lavet mange Hjemmesidefiler og aldrig tidligere haft problemet.
Med venlig hilsen
Erik Brindt
Legacy Deluxe 9.0.0.449 + Windows 10

Brugeravatar
Anne Marie H
Teamleder
Indlæg: 5119
Tilmeldt: søn 22-05-2005 22:17
Geografisk sted: Greve
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Anne Marie H » man 04-12-2023 10:50

Jeg har ingen problemer med at oprette Anetavle, og der er ingen fejlmeldinger om denne fejl fra andre brugere hverken i DK eller andre steder i verden. så fejlen ligger med stor sikkerhed hos dig.

Reinstallation af Legacy skal i øvrigt være en helt ren installation, så du skal sikre dig, at alle elementer af programmet er slettet ved at bruge afinstallationsfilen her C:\Program Files (x86)\Legacy9 > RemoveLegacy.exe
Husk at fjerne fluebenet, når du installerer igen, så du ikke får installeret Legacy i OneDrive!

De to instrukser du mangler er først denne
Unavngivet.jpg
(197.59 KiB) Ikke downloadet endnu
Find den og derefter skal du klikke på knappen Gendan for placering af midlertidige filer.

Hvis ingen af de tiltag, der er foreslået virker, så skal du eksportere din datafil til en ny Legacy-fil via fanen Fil > Eksport > Eksportér til ny Legacy-fil...
Venlig hilsen
Anne Marie Holck (Legacy Deluxe 9.0.0.456 + Windows 11)

Airtime
Indlæg: 73
Tilmeldt: man 23-02-2009 14:50
Geografisk sted: Gistrup
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Airtime » man 04-12-2023 16:14

Tak for svaret.
Jeg antager, at du selv har opgraderet til 9.0.0.449 selvom din signatur siger noget andet :D

Jeg prøver at køre hele processen forfra igen.
Kan du præcisere, hvor det flueben jeg skal fjerne, kommer.
Jeg forsøgte at være OBS på det ved reinstallationen, men jeg missede det åbenbart alligevel.
Med venlig hilsen
Erik Brindt
Legacy Deluxe 9.0.0.449 + Windows 10

Brugeravatar
Anne Marie H
Teamleder
Indlæg: 5119
Tilmeldt: søn 22-05-2005 22:17
Geografisk sted: Greve
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Anne Marie H » man 04-12-2023 18:18

Ja, det har jeg selvfølgelig - bare glemt at rette.

Fluebenet vedr OneDrive kan jeg ikke hjælpe med. Det er så længe siden, at jeg skiftede pc, og var gennem processen, så jeg kan simpelthen ikke huske det (og jeg var desværre ikke kvik nok til at notere det ned :cry:)
Venlig hilsen
Anne Marie Holck (Legacy Deluxe 9.0.0.456 + Windows 11)

Airtime
Indlæg: 73
Tilmeldt: man 23-02-2009 14:50
Geografisk sted: Gistrup
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Airtime » tors 07-12-2023 11:29

Jeg har nu været alle procedurerne igennem - uden effekt.

Selvom du skriver:

"Jeg har ingen problemer med at oprette Anetavle, og der er ingen fejlmeldinger om denne fejl fra andre brugere hverken i DK eller andre steder i verden. så fejlen ligger med stor sikkerhed hos dig".

vil jeg gerne forsøge med at rulle en opdateringsversion tilbage. Er det muligt :?:
Med venlig hilsen
Erik Brindt
Legacy Deluxe 9.0.0.449 + Windows 10

Airtime
Indlæg: 73
Tilmeldt: man 23-02-2009 14:50
Geografisk sted: Gistrup
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Airtime » søn 17-12-2023 13:47

Jeg har nu forsøgt følgende:

På min gamle PC, hvor Legacy ver. 9.0.0.384 er installeret, har jeg installeret filen fra min sikkerhedskopi.
Her kan jeg så uden problemer oprette min hjemmesidefil.

Så har jeg opdateret Legacy på min gamle PC til ver. 9.0.0.449.
Så optræder fejlen også her.

For mig at se, ligger fejlen altså i ver. 9.0.0.449.
Hvis ikke, hvordan forklares mine forsøg så :?:

Kan også lige fortælle, at jeg faktisk godt kan få produceret en hjemmesidefil, hvis jeg bare trykker "OK" på meddelelsen "Invalid procedure call or argument", hver gang den kommer, hvilket er 2-300 gange :)
Med venlig hilsen
Erik Brindt
Legacy Deluxe 9.0.0.449 + Windows 10

Brugeravatar
Anne Marie H
Teamleder
Indlæg: 5119
Tilmeldt: søn 22-05-2005 22:17
Geografisk sted: Greve
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Anne Marie H » søn 17-12-2023 20:33

Jeg bliver nødt til at henvise dig til den amerikanske support, da jeg ikke har mulighed for at gå nærmere dybden med den fejl, du oplever.

Du skal skrive til support@legacyfamilytree.com

Inden du gør det, kan du evt. prøve at sende mig din fil (som .fdb-fil - ikke gedcom), så skal jeg gerne tjekke, om fejlen optræder her hos mig.
Venlig hilsen
Anne Marie Holck (Legacy Deluxe 9.0.0.456 + Windows 11)

Airtime
Indlæg: 73
Tilmeldt: man 23-02-2009 14:50
Geografisk sted: Gistrup
Kontakt:

Re: Invalid Procedure Call or Argument

Indlægaf Airtime » søn 24-12-2023 16:09

Jeg har nu fundet årsagen til fejlmeddelelserne.

De skyldes, at jeg bruger tegnene "<" og ">" i forbindelse med et årstal i "Dato" rubrikken under "Begivenheder/fakta".
Det har aldrig tidligere givet anledning til problemer, og jeg har brugt dem i mange år og lavet utallige udskrifter uden problemer, men...

Ved indtastning i nyeste version .449 laver Legacy automatisk tegnene "<" og ">" om til hhv. "før" og efter".
Men når tegnene er indskrevet i en tidligere version, der nu er opdateret til ver. 449, kan Legacy ikke finde ud af det og fejlmelder.
Med venlig hilsen
Erik Brindt
Legacy Deluxe 9.0.0.449 + Windows 10


Tilbage til "Hjemmesider"

Hvem er online

Brugere der læser dette forum: Ingen og 1 gæst